http://poradumo.pp.ua

Online Журнал-Світ порад.
Головна сторінка
» » Excel: "Якщо" (формула). В Excel функція "Якщо"

Excel: "Якщо" (формула). В Excel функція "Якщо"

Сьогодні ми розповімо про функції табличного редактора Excel «Якщо». Вона має відношення до логічних можливостей програми. Її можна віднести до найбільш затребуваних функцій під час роботи.

Ключові можливості

Excel: "Якщо" (формула). В Excel функція "Якщо"
В Excel формула «Якщо» допомагає виконувати різного роду завдання, коли потрібно порівняти певні дані і отримати результат. Дане рішення дає можливість застосовувати розгалужені алгоритми, а також створювати дерево рішень.

Приклади використання

Excel: "Якщо" (формула). В Excel функція "Якщо"
Функція виглядає таким чином: =ЯКЩО (завдання; істина, брехня). Перша складова частина — логічне вираження. Воно може бути фразою або числом. Наприклад, «10» або «без ПДВ» — це логічні вирази. Даний параметр обов'язково необхідно заповнити. Істина — це значення, яке відображається як результат, якщо вираз буде вірним. Брехня — дані, які будуть видані, коли завдання не буде вірною.




Рівність параметрів двох осередків

Excel: "Якщо" (формула). В Excel функція "Якщо"
Для розуміння можливостей функції «Якщо» в Excel, приклади просто необхідні, і далі ми перейдемо до їх розгляду. Вводимо в клітку C1 показник 8. Далі в полі за адресою D1 вводимо наступну формулу: =если(C1 <10; 1; 2). Таким образом, программа начнет сравнивать значение из клетки C1 с параметром 10. Когда оно будет меньше десяти, в поле по адресу D1 появится единица. В обратном случае редактор укажет число 2. Рассмотрим еще одну задачу. Есть перечень студентов и их оценки, полученные по экзамену. Данные таковы: 5, 4, а также 3 и 2. Условие задачи предполагает создание для каждого из студентов текстового комментария «сдал» либо «не сдал». Другими словами, если учащийся получил оценку три и выше, он с экзаменом справился. Если его бал ниже 3 – студент не сдал. Чтобы решить эту задачу пишем такую формулу: =ЕСЛИ(C1, =, <=.




Приклади з застосуванням умов «АБО», «І»

Excel: "Якщо" (формула). В Excel функція "Якщо"
Продовжуємо практикуватися і освоювати логічні можливості програми. Функцію табличного редактора Excel «Якщо» можна з'єднати з операторами порівняння. До них відносяться параметри: «АБО», «І». Зазначимо необхідна умова в Excel: якщо оцінка учня дорівнює або менше 5 але не більше 3. Повинен бути відображений коментар: «проходить». В іншому разі – «ні». Отже, проходять лише ті учні, які отримали п'ятірки і четвірки. Записати подібну задачу в табличному редакторі можна використовуючи спеціальну формулу. Вона буде мати вигляд: =ЕСЛИ(І(A1 3); «проходить», «ні»). До більш складного прикладу можна віднести використанням «або» АБО «І». Отже подивимося, як застосовувати формулу в Excel, якщо кілька умов у задачі. Приклад такого виразу: =ЕСЛИ(АБО(A1=5; A1=10); 100; 0). З цього випливає, що якщо показник в клітці А1 дорівнює 5 або 10 програма відобразить результат 100 у протилежному випадку — 0. Можна використовувати ці оператори і щоб вирішити більш складні завдання. Наприклад, в базі необхідно обчислити боржників, яким необхідно заплатити більше 10000 рублів. При цьому вони не погашали позику більше шести місяців. Функція табличного редактора Excel «Якщо» дозволяє в автоматичному режимі отримати навпроти відповідних імен позначку «проблемний клієнт». Припустимо, у клітці A1 розташовані дані, що вказують на термін заборгованості (місяці). Поле B1 відображає суму. У цьому випадку формула буде мати наступний вигляд: =ЕСЛИ(І(A1>=6; B1>10000); «проблемний клієнт»; «»). Звідси випливає, що якщо буде виявлено людина, який відповідає зазначеним умовам, програма вкаже навпроти його імені необхідний коментар. Для всіх інших учасників переліку аналогічна клітина залишиться порожньою. Розглянемо приклад для випадку, коли ситуація є критичною. Введемо відповідний коментар. В результаті формула буде мати наступний вигляд: =ЕСЛИ(АБО(А1>=6; B1>10000); «критична ситуація»; «»). В такому випадку, якщо програма виявить збігу як мінімум по одному з параметрів (термін, сума заборгованості), користувач побачить відповідна примітка. У першій ситуації повідомлення «проблемний клієнт» видавалося лише тоді, коли були виконані обидва заданих умови.


Завдання високого рівня складності

Excel: "Якщо" (формула). В Excel функція "Якщо"
Функція табличного редактора Excel «Якщо» використовується, щоб обійти вбудовані помилки при діленні на нуль, а також ще в декількох випадках. Перша ситуація позначається редактором, як «СПРАВ/0» і зустрічається досить часто. Як правило, вона виникає в тих випадках, коли підлягає копіюванню формула «A/B», при цьому показник B в окремих клітинках дорівнює нулю. Уникнути цього можна за допомогою можливостей розглянутого нами оператора. Отже, необхідна формула буде мати наступний вигляд: =ЕСЛИ(B1=0; 0; A1/B1). Звідси випливає, що якщо клітина B1 буде заповнена параметром «нуль», редактор видасть «0», у зворотному випадку Excel поділить показник A1 на дані B1 і відобразить результат.


Знижка

На практиці часто зустрічається ситуація, яка буде розглянута далі. Йдеться про розрахунок знижки, виходячи із загальної суми коштів, витрачених на придбання певного товару. Використовувана в цьому випадку матриця може мати наступний вигляд: менше 1000 — 0%; 1001-3000 — 3%; 3001-5000 — 5%; більш 5001 — 7%. Розглянемо ситуацію, коли в Excel присутня база даних відвідувачів, а також інформація про суму витрачених ними на придбання засобів. Тепер необхідно розрахувати знижку для кожного клієнта. З цією метою використовуємо наступне вираз: =ЯКЩО(A1>=5001; B1*093; ЯКЩО(А1>=3001; B1*095;). Система перевіряє загальну суму покупок. Коли вона перевищує показник 5001 рублів, відбувається множення на 93 відсотка вартості товару. У разі подолання позначки в 3001 одиницю, має місце аналогічна дія, але вже з урахуванням 95%. Наведену формулу з легкістю можна застосовувати на практиці. Обсяг продажів і показники знижок задаються на розсуд користувача.

Застосування описаних можливостей можливе для вирішення різного роду завдань. Основний етап — правильне складання формули, щоб не отримати помилкового результату. Тепер ви знаєте, як використовувати оператор в Excel, якщо кілька умов у задачі.

of your page -->

Популярні поради

загрузка...